Forum Forum Fortifications of the World
A web site about fortifications and freeware programs : Fortifications of the World
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problems adding new records

 
Post new topic   Reply to topic    Forum Fortifications of the World Forum Index -> HappyCollection
View previous topic :: View next topic  
Author Message
rbishop41



Joined: 30 Jan 2010
Posts: 11
Location: Melbourne Australia

PostPosted: Sat Jan 30, 2010 10:15 pm    Post subject: Problems adding new records Reply with quote

I use the database for my coin collection, and currently have 933 records. When I attempt to add a new record, I get the message "Post Error while insert reference" and then "Unknown internal operating system error. Table C:\Program Files\HappyCollection_V2.5\COLLECT1.DB". The new record is not added.

The problem occurs both when I use Creation - Duplicate and when I just try to create without duplicating an existing record.

I am running Windows 7, but get the same problem when doing the same thing on a Windows XP machine.

Can you sugget a solution? Question
Back to top
View user's profile Send private message
ale
Site Admin


Joined: 12 Apr 2005
Posts: 474
Location: Versailles, France

PostPosted: Thu Feb 04, 2010 9:23 am    Post subject: Reply with quote

First of all, i would suggest not to use the "C:\Program Files\..." directory to store your databases : Athough it should not make problems with Windows XP, Vista and Seven will not like it.
Create instead a specific directory, for instance "C:\Users\YourLogin\Data\HappyCollection_databases\", declare it in HappyCollection (Tab Databases -> Repertoire des bases", and put your files COLLECT1 to COLLECT7 here.

About your problem, it sems that your database has been corrupted for some reason (power failure ? deep-end of Windows ? ...)
I would suggest that you send to me the 2 files COLLECT1.DB and COLLECT1.MB, for analysis and repair.
Back to top
View user's profile Send private message
rbishop41



Joined: 30 Jan 2010
Posts: 11
Location: Melbourne Australia

PostPosted: Thu Feb 04, 2010 9:46 am    Post subject: Reply with quote

As far as I can see, under tab Databases there is no option "Repertoire des bases". Options available on my copy of the program (V2.5) are:
Choose program options
Choose field caption
Choose colours
Picture directory

The program options relate only to language, Image 1 and automatic backup.

I have worked around the problem - not sure how it worked. I copied the 4 Collect1 files to a temporary location. Renamed them Collect2 and they worked ok as Database 2. I then deleted the original Collect1 files and copied the Collect2 files to Collect1. I now have 2 working versions. I don't use databases 3-7 at present.

When it works, which is most of the time, your program is superb. Many thanks.
Back to top
View user's profile Send private message
rbishop41



Joined: 30 Jan 2010
Posts: 11
Location: Melbourne Australia

PostPosted: Sat Mar 20, 2010 12:19 am    Post subject: Unable to add new records Reply with quote

Hi.

My problem has recurred, and I have been unable to fix it as I did once before.

Can you please let me have your email address so I can send you the two files for repair.
Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Forum Fortifications of the World Forum Index -> HappyCollection All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group